Welcome, Guest
Username: Password: Remember me

TOPIC: 182S Fuel Sending Unit problems

182S Fuel Sending Unit problems 5 months 6 days ago #923

Hello Steve. This is awesome advice. Thank you so much for responding so quickly. I will let you know how this turns out. And, by the way, I do not have a G1000 panel, all steam gauges (which I prefer).
Thanks again!
The administrator has disabled public write access.

182S Fuel Sending Unit problems 5 months 6 days ago #920

  • STEVE ELLS
  • STEVE ELLS's Avatar
  • Offline
  • Expert Boarder
  • Posts: 131
  • Thank you received: 27
  • Karma: 3
Just a couple of thoughts based on the assumption that you do not have the Garmin 1000 installed. 1) There are a couple of potentiometers on the side of the fuel indicator gauge to set empty and full. Potentiometers do create problems; not sure if it's possible for these "pots" to be the source of the problem but my logic says it's possible.
Secondly, CIESCorp.net sells very good fuel senders that are approved for installation in your airplane. Cost is $395 each. If you're not happy with the Cessna product, I think the CIES senders will work.
Scott Philben at CIES may be able to help with trouble shooting your problem.
Please let me know what you find.
The administrator has disabled public write access.

182S Fuel Sending Unit problems 5 months 1 week ago #919

Hello, I have a 1997 182S that has fuel gauge operability issues. When this plane came home from Florida to Virginia for the first time, I noticed one of the fuel gauges would go from reading the amount to empty, and then back again intermittently. Once home, I asked the local A&P to have a look. They cleaned up the contacts and said everything appeared better. On the next flight, the same problem arose again. The recommendation was then to just replace the fuel gauge sending unit with a new one. Additionally, there were no STC'd version of this sending unit as Textron had released a revised deign and no one had made a comparable unit. I told the A&P to just replace both sides as it was more cost effective knowing the effort needed to take apart the headliner and drain the tanks. They ordered two new units from Textron and installed them.
The first day of flying after the new sending units were installed, I had the tanks topped off and went on a short cross country with my instructor. Right after startup, one of the gauges went to empty. Then, during taxi, it went back to full. During run-up, the other gauge went to empty and returned to full on takeoff. Very frustrated, I called the A&P and told him what was going on.
After they pulled everything back apart again and did some very thorough testing,, it was finally determined that both new sending units were defective. When they would go to a certain level, the resistance would go out of spec. Textron was called and said they will send two new ones. The A&P told me there is lots of chatter out online that this is a known issue with these re-designed sending units. I was astounded. Is it possible that Textron knows these units are defective and are continuing to send them out to put in aircraft? Is this a design issue and they are not admitting to it or actually fixing it?
This repair is going to cost a tremendous amount due to all the time spent taking things apart and putting them back together. I am thinking the two new units to ne installed this week will also have problems. And if the issues do not surface on day one, how many months later until it happens again? Has anyone experienced this? Is this really a prevalent problem? Does the FAA know this is going on? We are supposed to have working fuels gauges not ones that work when they want to after placing brand new parts in...
Please let me know if anyone can give me some good advice on where to go next with this..
Many thanks. :(
The administrator has disabled public write access.
Time to create page: 0.349 seconds